通达信龙头主图指标公式

指标公式 7次浏览

通达信龙头主图指标公式

REF(下,1))/REF(下,1)*100,NODRAW;
A2X:=(A2REF(A2,1))/REF(A2,1)*100,NODRAW;
买:IF(A1X>=0,多空,DRAWNULL),COLORMAGENTA,LINETHICK3;
卖:IF(A1X<0 AND A2X<0,多空,DRAWNULL),COLORGREEN,LINETHICK3;
{STICKLINE(做多>做空,做多,做空,3,0),COLORRED;
STICKLINE(做多<=做空,做多,做空,3,1),COLORGREEN;}
{水平支撑压力}
HIGHN:=10;
HIGHN8:=20;
LOWN:=10;HIGHDISPLAY:=0;LOWDISPLAY:=0;ZGDISPLAY:=0;MADISPLAY:=0;
AA:=REF(H,HIGHN)=HHV(H,2*HIGHN+1);
QY:=BACKSET(AA,HIGHN+1);
CC:=FILTER(QY,HIGHN) AND H=HHV(H,HIGHN+1);
DDDD:=BARSLAST(CC);
GDTS:=IF(CC,CURRBARSCOUNT,0);
DINGBU:=IF(DDDD,REF(H,DDDD),H);
DINGBUTS:=IF(DDDD,REF(GDTS,DDDD),GDTS);
DINGBU1:=REF(DINGBU,DDDD+1);
GDCS1:=CONST(DINGBUTS);
DINGBUTS1:=REF(DINGBUTS,DDDD+1);
GDCS2:=CONST(DINGBUTS1);
DINGBU2:=REF(DINGBU1,DDDD+1);
MM:=IF(CURRBARSCOUNT>GDCS2,0,1);
CC8:=FILTER(QY,HIGHN8) AND H=HHV(H,HIGHN8+1);
DDDD8:=BARSLAST(CC8);
GDTS8:=IF(CC8,CURRBARSCOUNT,0);
DINGBUTS8:=IF(DDDD8,REF(GDTS8,DDDD8),GDTS8);
GDCS8:=CONST(DINGBUTS8);
DINGBUTS9:=REF(DINGBUTS8,DDDD8+1);
GDCS9:=CONST(DINGBUTS9);
高点压力:=DRAWLINE(CURRBARSCOUNT=GDCS2,H,CURRBARSCOUNT=GDCS1,H,1) COLORGREEN,LINETHICK1;
压A:DRAWLINE(CURRBARSCOUNT=GDCS2,H,ISLASTBAR,REF(H,GDCS21),1),COLOR0055FF,LINETHICK2;
压B2:=DRAWLINE(CURRBARSCOUNT=GDCS8,H,ISLASTBAR,REF(H,GDCS81),1),COLORCYAN;
{高低连线支撑压力}
A1:=REF(H,8)=HHV(H,2*8+1);
B1:=FILTER(A1,8);
C1:=BACKSET(B1,8+1);
D1:=FILTER(C1,8);
R11:=BACKSET(ISLASTBAR,BARSLAST(D1)+1); S11:=R11>REF(R11,1);
A2B:=REF(L,8)=LLV(L,2*8+1);
B2:=FILTER(A2B,8);
C2:=BACKSET(B2,8+1);
D2:=FILTER(C2,8);
T11:=BACKSET(ISLASTBAR,BARSLAST(D2)+1); U11:=T11>REF(T11,1);
M:=INTPART(3*8/5);
A12:=REF(H,M)=HHV(H,2*M+1);
B12:=FILTER(A12,M);
C12:=BACKSET(B12,M+1);
D12:=FILTER(C12,M);
R112:=BACKSET(ISLASTBAR,BARSLAST(D12)+1); S112:=R112>REF(R112,1);
A22:=REF(L,M)=LLV(L,2*M+1);
B22:=FILTER(A22,M);
C22:=BACKSET(B22,M+1);
D22:=FILTER(C22,M);{低点}
T112:=BACKSET(ISLASTBAR,BARSLAST(D22)+1); U112:=T112>REF(T112,1);
压1:DRAWLINE(D1,H,S11,H,1),COLORGREEN;
压2:DRAWLINE(D12,H,S112,H,1),COLORLIBLUE;
支1:=DRAWLINE(D2,L,U11,L,1),COLORRED;
支2:=DRAWLINE(D22,L,U112,L,1),COLORLIRED;
{变动支撑压力}
PH:=TROUGHBARS(2,5,1);
LL:=HHV(H,PH);
TJ1:=LL=HIGH AND LL<REF(LL,1);
TS:=SUMBARS(TJ1,2);
TJ:=PEAKBARS(2,5,1)=1 AND TS>=PH;
PL:=BARSLAST(TJ);
支C:=IF(BARSLAST(TJ1),REF(LOW,BARSLAST(TJ1)),DRAWNULL),COLOREA91B5;
压C:=IF(BARSLAST(TJ),REF(HIGH,PL),DRAWNULL),COLORYELLOW;
{涨停表示}
LA:=BARSLAST(C>REF(C,1)*1.098);
LC:=REF(CLOSE,LA);
LO:=REF(OPEN,LA);
LAL:=REF(L,LA);
LAH:=REF(H,LA);
一涨停:=EVERY(C/REF(C,1)>=1.097 AND C=H,1);
双涨停:=EVERY(C/REF(C,1)>=1.097 AND C=H,2);
三涨停:=EVERY(C/REF(C,1)>=1.097 AND C=H,3) AND H>L;
策略1A:=EXIST((C/REF(C,2)REF(C,1))*100/REF(C,1)>=(109.9,O,C,1,0),COLORBLUE;

通达信龙头主图指标公式的选股公式


喜欢 (0)