通达信军师和将军主图指标公式

A14;
DIS2:=A2A11;
DIS5:=A5-A10;
DIS6:=A6-A9;
DIS0:=(A1+A2+A3+A4+A5+A6)/6;
DIS00:MA(DIS0,49),LINETHICK3,COLORBLUE;
向下:=IF(DIS00<REF(DIS00,Y),1,0);
一直向上:=IF(COUNT(向下,60)<30,1,0);
红色将军:=IF(B14>=REF(B14,Y)AND B13 >= REF(B13,Y) AND B12 >= REF(B12,Y) AND B11 >= REF(B11,Y) AND B10 >= REF(B10,Y) AND 一直向上,1,0),COLORRED,LINETHICK0;
STICKLINE(红色将军,B14,B1,5,0),COLORRED;
HAHAHA1:=IF(B1>=REF(B1,Y),1,0),LINETHICK0;
STICKLINE(HAHAHA1,B1,B3,5,0),COLORC0A6D1;
绿色军师0:=IF((B1<=REF(B1,Y) OR B2<REF(B2,Y) OR B3<REF(B3,Y) OR B4<REF(B4,Y) OR B5<REF(B5,Y)) AND B14>=REF(B14,Y) AND B13>REF(B13,Y) AND (B12>REF(B12,Y) OR B11>REF(B11,Y))AND COUNT(红色将军,70)<35 AND C/LLV(C,170)<1.8,1,0);
绿色军师1:=IF(股龄>990 AND 绿色军师0 AND C/LLV(C,1000)<4.5,1,0);
绿色军师2:=IF(股龄>490 AND 绿色军师0 AND C/LLV(C,500)<2.5,1,绿色军师1);
绿色军师:=IF(股龄<490 AND 绿色军师0,1,绿色军师2),COLORGREEN,LINETHICK0;
STICKLINE(绿色军师,B6,B11,4,0),COLORGREEN;
副军师在此:=IF(绿色军师 AND COUNT(绿色军师,50)<=1,1,0);
DRAWTEXT(副军师在此,A14*0.87,'>>副军师在此<<'),COLORGREEN;
黄色军师0:=IF(B1<=REF(B1,Y) AND B14>=REF(B14,Y) AND B13>REF(B13,Y) AND B12>REF(B12,Y) AND B11>REF(B11,Y)AND COUNT(红色将军,70)<35 AND COUNT(红色将军,210)<40 AND C/LLV(C,170)<1.8,1,0);
黄色军师1:=IF(股龄>990 AND 黄色军师0 AND C/LLV(C,1000)<3.5,1,0);
黄色军师2:=IF(股龄>490 AND 黄色军师0 AND C/LLV(C,500)<2.5,1,黄色军师1);
黄色军师:=IF(股龄<490 AND 黄色军师0,1,黄色军师2),COLORYELLOW,LINETHICK0;
STICKLINE(黄色军师,B6,B11,4,0),COLORYELLOW;
军师在此:=IF(黄色军师 AND COUNT(黄色军师,50)<=1,1,0);
DRAWTEXT(军师在此,A14,'>>军师在此<<'),COLORYELLOW;
DIS000:MA(DIS0,49),LINETHICK5,COLORBLUE;
ABC:=EMA(C,15);
STICKLINE(C<ABC,H,L,0.4,2),COLORGREEN;
STICKLINE(C<ABC,O,C,8,2),COLORGREEN;
STICKLINE(C>ABC,H,L,0.4,2),COLORRED;
STICKLINE(C>ABC,O,C,8,2),COLORRED;

通达信军师和将军主图指标公式的选股公式