通达信TO神器分时主图指标公式

通达信TO神器分时主图指标公式

SUM(IF(C<REF(C,1),攻击量*V,0),FROMOPEN),COLOR00FF00,LINETHICK0;
攻击流量:=攻击量A+攻击量B,COLORSTICK;
攻击比:=攻击流量/SUM(V,FROMOPEN)*100,COLORRED,LINETHICK1;
资金攻击:=IF(攻击比>=0,(攻击比+50),100SUM(IF(C<REF(C,1),V,0),FROMOPEN),STICK,COLOR00FF00;
资金出入:=资金流入+资金流出,COLORSTICK;
资金比:=资金出入/SUM(V,FROMOPEN)*100,COLOR00FFFF,LINETHICK1;
资金流比:=IF(资金比>=0,(资金比+100)/2,100DATETODAY(REF(DATE,TOTALBARSCOUNTREF(WEEKDAY,1) OR TOTALBARSCOUNTDEA);
MACD2:=EMA(MACD1,2);
STICKLINE(MACD1>=MACD2 AND MACD1>=0,DYNAINFO(3),MACD1+DYNAINFO(3),0,0),COLOR0000B4;
STICKLINE(MACD1<MACD2 AND MACD1>0,DYNAINFO(3),MACD1+DYNAINFO(3),0,0),COLOR00B400;
STICKLINE(MACD1>=MACD2 AND MACD1<0,DYNAINFO(3),MACD1+DYNAINFO(3),0,0),COLOR5151A2;
STICKLINE(MACD1<MACD2 AND MACD1<0,DYNAINFO(3),MACD1+DYNAINFO(3),0,0),COLOR88743A;
XX:=SUM(AMOUNT,BARSCOUNT(CLOSE))/SUM(V*100,BARSCOUNT(CLOSE));
主力:=EXPMA(CLOSE/XX,20);大户:=EXPMA(CLOSE/XX,60);散户:=EXPMA(CLOSE/XX,120);
底:=1;1.02,NODRAW;高:=1.03;
DRAWTEXT(CROSS(主力,1.02),C*0.999,'0.05,0,STRCAT(STRCAT('【机构买盘】',CON2STR(机构买盘,2)),'万')),COLORYELLOW;
DRAWTEXT_FIX(1,0.18,10.05,0,STRCAT(STRCAT('【散户卖盘】',CON2STR(散户卖盘,2)),'万')),COLOR00FF00;
H1:=MAX(DYNAINFO(3),DYNAINFO(5));
L1:=MIN(DYNAINFO(3),DYNAINFO(6));
P1:=H1FINANCE(21))/FINANCE(20)*100,2));
净利润率:=STRCAT('净利润率 ',CON2STR(FINANCE(30)/FINANCE(20)*100,2));主营利润率:=STRCAT('主营利润率 ',CON2STR(FINANCE(23)/FINANCE(20)*100,2));利润同比:=STRCAT('利润同比: ',CON2STR(FINANCE(43),2));收入同比:=STRCAT('收入同比: ',CON2STR(FINANCE(44),2));X1:=(FINANCE(11)FINANCE(22)2*STD(CLOSE,20),NODRAW,COLORMAGENTA,LINETHICK2;DRAWTEXT_FIX(1,0.0001,0.00,0,STRCAT(STRCAT('【今日强势有效突破】',CON2STR(上穿分时,2)),' 元买入稳赚')),COLORWHITE,LINETHICK1;
DRAWTEXT_FIX(1,0.5001,0.00,0,STRCAT(STRCAT('【底部得到有效支撑】',CON2STR(底支,2)),' 元 可以参考')),COLORWHITE,LINETHICK1;
所属板块:=STRCAT('【所属板块】',STRCAT(STRCAT(STRCAT(' [行业]—',HYBLOCK),STRCAT(' [地域]—',DYBLOCK)),STRCAT(' [概念]—',GNBLOCK)));
DRAWTEXT_FIX(ISLASTBAR,0.005,0.05,0,所属板块),COLORWHITE;
主营收入同比:=FINANCE(44);{主营收入同比增长率}
净利润同比:=FINANCE(43);{净利润同比增长率}
市盈:=DYNAINFO(39);
市净:=CONST(DYNAINFO(7) / FINANCE(34));
净利:=CONST(FINANCE(30)/FINANCE(20));
DRAWTEXT_FIX(1,0.72,0.71,0,'市盈:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.79,0.71,0,CON2STR(市盈,2)),COLORRED;
DRAWTEXT_FIX(1,0.72,0.77,0,'市净:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.79,0.77,0,CON2STR(市净,2)),COLORWHITE;
DRAWTEXT_FIX(1,0.72,0.83,0,'净利:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.79,0.83,0,CON2STR(净利,2)),COLORWHITE;
DRAWTEXT_FIX(1,0.72,0.89,0,'主营同比:'),COLORWHITE;
DRAWTEXT_FIX(1,0.79,0.89,0,STRCAT(VAR2STR(主营收入同比,0),' %')),COLORYELLOW;
DRAWTEXT_FIX(1,0.72,0.95,0,'净利同比:'),COLORWHITE;
DRAWTEXT_FIX(1,0.79,0.95,0,STRCAT(VAR2STR(净利润同比,0),' %')),COLORYELLOW;
换手:=VOL/CAPITAL*100;
五换:=MA(换手,5);
DRAWTEXT_FIX(1,0.87,0.71,0,'今换:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.91,0.71,0,STRCAT('',CON2STR(换手,2))),COLORWHITE;
DRAWTEXT_FIX(1,0.87,0.77,0,'五换:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.91,0.77,0,STRCAT('',CON2STR(五换,2))),COLORWHITE;
DRAWTEXT_FIX(1,0.87,0.83,0,'量比:'),COLORWHITE;
DRAWTEXT_FIX(1,0.91,0.83,0,STRCAT('',CON2STR(DYNAINFO(17),2))),COLORRED;
DRAWTEXT_FIX(1,0.87,0.89,0,'内盘:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.91,0.89,0,STRCAT('',CON2STR(DYNAINFO(22),0))),COLORGREEN;
DRAWTEXT_FIX(1,0.87,0.95,0,'外盘:'),COLORYELLOW;
DRAWTEXT_FIX(1,0.91,0.95,0,STRCAT('',CON2STR(DYNAINFO(23),0))),COLORRED;

通达信TO神器分时主图指标公式的选股公式