通达信龙凤呈祥主图指标公式

指标公式 6次浏览

通达信龙凤呈祥主图指标公式

REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
CB:=EMA(VAR4,13);
{红}
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,3,0),COLOR0000FF;
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,0.5,0),COLORCC66FF;
{蓝}
STICKLINE(CLOSE<OPEN,CLOSE,OPEN,3,0),COLORFF9900;
STICKLINE(CLOSE<OPEN,CLOSE,OPEN,0.5,0),COLORFFCC00;
{粉}
STICKLINE(VAR1,C,(O+C)/2,3,0),COLORFF11FF;
STICKLINE(VAR1,C,(O+C)/2,0.5,0),COLORFFDDFF;
{灰}
STICKLINE(VAR2,C,(O+C)/2,3,0),COLOR999999;
STICKLINE(VAR2,C,(O+C)/2,0.5,0),COLORFFBBFF;
{绿}
STICKLINE(VAR3,O,(O+C)/2,3,0),COLOR00BB00;
STICKLINE(VAR3,O,(O+C)/2,0.5,0),COLOR00FF00;
卖:=HHV(DX,2)=HHV(DX,7) AND COUNT(DX>50,2) AND CROSS(MA(DX,2),DX);
DRAWTEXT(FILTER(卖=1,1),HIGH*1.02,’冲高卖’),COLORGREEN;
买:=LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2));
DRAWTEXT(FILTER(买=1,5),LOW0.03,”),COLORWHITE;
跟:=MA18>=REF(MA18,3) AND CROSS(CLOSE,MA18);
DRAWTEXT(跟,LOW*0.96,’跟’),COLORCC66FF;
所属板块:=STRCAT(‘【所属板块】’,STRCAT(STRCAT(STRCAT(‘ [行业]—’,HYBLOCK),STRCAT(‘ [地域]—’,DYBLOCK)),STRCAT(‘ [概念]—’,GNBLOCK)));
总股本:=STRCAT(STRCAT(‘ 总股本:’,CON2STR(TOTALCAPITAL/1000000,2)),’亿’);
流通盘:=STRCAT(STRCAT(‘ 流通盘:’,CON2STR(CAPITAL/1000000,2)),’亿’);
全流通:=STRCAT(STRCAT(‘ 流通比:’,CON2STR(CAPITAL/TOTALCAPITAL*100,2)),’%’);
市值:=STRCAT(STRCAT(‘ 流通市值:’,CON2STR((CAPITAL/1000000)*C,2)),’亿’);
上市日期:=STRCAT(‘ 上市日期: ‘,CON2STR(HHV((BARSCOUNT(C)=0)*(DATE+19000000),0),0));
股本市值:=STRCAT(‘【股本市值】’,STRCAT(STRCAT(STRCAT(STRCAT(总股本,流通盘),全流通),市值),上市日期));
市盈率:=STRCAT(‘ 市盈率:’,CON2STR(C/FINANCE(33),2));
市销率:=STRCAT(‘ 市销率:’,CON2STR(C/(FINANCE(20)/FINANCE(1)),2));
市净率:=STRCAT(‘ 市净率:’,CON2STR(C/FINANCE(34),2));
净资收益率:=STRCAT(‘ 净资收益率:’,CON2STR(FINANCE(33)/FINANCE(34)*100,2));
毛利率:=STRCAT(‘ 毛利率:’,CON2STR((FINANCE(20)Z值: ‘,CON2STR(Z值,3))));
优质资产率:=STRCAT(‘ 优质资产率: ‘,CON2STR((FINANCE(19)-FINANCE(22)-FINANCE(27))/FINANCE(19),2));{理论上越大越好但不同行业有不同标准};
现金负债比:=STRCAT(‘ 现金负债比: ‘,CON2STR(FINANCE(25)/FINANCE(15),3));{缺长期负债或负债总额,理论上越大越好但不同行业有不同标准};
财务系数:=STRCAT(‘风险系数: ‘,STRCAT(STRCAT(财务预警,优质资产率),现金负债比));
DRAWTEXT_FIX(ISLASTBAR,0.005,0.23,0,财务系数),COLORGREEN;

通达信龙凤呈祥主图指标公式的选股公式


喜欢 (0)