通达信线性回归主图指标公式

指标公式 9次浏览

通达信线性回归主图指标公式

20191,止盈线,DRAWNULL),COLORCYAN,LINETHICK1;
DRAWICON(REF(MIDD,1)<=REF(MIDD,2) AND MIDD>REF(MIDD,1),DOWN,7);
DRAWICON(REF(MIDD,1)>=REF(MIDD,2) AND MIDD<REF(MIDD,1),UP,8);
{线性回归画线}
UR:=15;LR:=15;{可调}
TC1:=IF(C=HHV(C,5*UR),C,DRAWNULL);
TC2:=CONST(BARSLAST(TC1=C))+1;
BC1:=IF(L=LLV(L,5*LR),L,DRAWNULL);
BC2:=CONST(BARSLAST(BC1=L))+1;
NOD:=(IF(TC2>BC2,TC2,BC2)1)));
FP:=NP1;
LRL:=IF(NP>FP,FP+AD/NOD*BSP,FPLRL=AT2));
AT5:=CONST(IF(AT3=0,AT1UT1,MAX(BC2,TC2));
UT3:=CONST(BARSLAST(LRLUT1,UT3)));
UTL:=LRL11)));
RL:=IF(CURRBARSCOUNT>=MIN(BC2,TC2)UTL<ATLLRL<LRLLRL),DRAWNULL)),IF(LRLUTL,IF(ATL(ATL1))),DRAWNULL),POINTDOT,COLOR93BDA8;
LR2A:=SLOPE(C,NODA+1);
LR3A:=CONST(IF(MIN(TC2A,BC2A)=1,LR2A,REF(LR2A,MIN(TC2A,BC2A)FPA);
DBLA:=BARSLAST(BC1A!=DRAWNULL)+1;
DBHA:=BARSLAST(TC1A!=DRAWNULL)+1;
BSPA:=IF(BC2A>TC2A,DBLA,DBHA)LRLA,MAX(BC2A,TC2A));
AT3A:=CONST(BARSLAST(AT1ALRLA,AT3A)));
ATLA:=LRLA+AT5A;
UT1A:=IF(BETWEEN(CURRBARSCOUNT,BC2A,TC2A) AND L<LRLA,L,LRLA);
UT2A:=HHV(LRLAUT1A,REF(LRLA10,ATLA,CONST(REF(ATLA,MIN(BC2A,TC2A)11)));
中轨A:=IF(NPA>FPA,IF(LRLA<=RHA,LRLA,DRAWNULL),IF(LRLA>=RLA,LRLA,DRAWNULL)),COLOR628962;
上轨12A:IF(NPA>FPA,IF(ATLA<=RHA,ATLA,DRAWNULL),IF(ATLA>=RLA,ATLA,DRAWNULL)),COLORWHITE;
下轨12A:IF(NPA>FPA,IF(UTLA<=RHA,UTLA,DRAWNULL),IF(UTLA>=RLA,UTLA,DRAWNULL)),COLORWHITE;
IF(NPA>FPA,IF(LRLAUTLA,IF(ATLA(ATLALRLA,LRLA*2UTLA,LRLA-(ATLA-LRLA),DRAWNULL))),DOTLINE,COLORWHITE;

通达信线性回归主图指标公式的选股公式


喜欢 (0)