通达信不断创新高主图指标公式

指标公式 10次浏览

通达信不断创新高主图指标公式

2019REF(MA(CLOSE,12),1));
B:=MA(CLOSE,12)+MA(CLOSE,12)分水岭);
AA:=CROSS(分水岭,操作线);
STICKLINE(AA,C,O,3,0),COLOR0000AA;
STICKLINE(AA,C,O,2,0),COLOR0033CC;
STICKLINE(AA,C,O,1,0),COLOR0055EE;
STICKLINE(AA,C,O,0.3,0),COLOR0099FF;
STICKLINE(AA,H,L,0,1),COLOR0099FF;
RR:=CROSS((MA(VOL,5)),(MA(VOL,10))) AND MA(C,2)>=MA(C,4); {AND VOL>=REF(VOL,1)}
STICKLINE(RR,C,O,3,0),COLOR0000AA;
STICKLINE(RR,C,O,2,0),COLOR0033CC;
STICKLINE(RR,C,O,1,0),COLOR0055EE;
STICKLINE(RR,C,O,0.3,0),COLOR0099EE;
STICKLINE(RR,H,L,0,1),COLOR0099FF;
MA5:MA(CLOSE,5),NODRAW;
MA10:MA(CLOSE,10),COLORCC66FF;
MA20:MA(CLOSE,20),COLORFFCC66,LINETHICK2;
MA60:MA(CLOSE,60),COLOR00FF99,LINETHICK2;
MA120:MA(C,120),COLORGRAY;
MA250:MA(CLOSE,250),COLORBLUE;
DRAWICON(CROSS(MA60,MA120),MA60,25); {60日上穿120日做记号}
DRAWICON(CROSS(MA120,MA60),MA60,15); {120日下穿60日做记号}
STICKLINE(C<0.90*REF(C,1),C,O,3,0),COLORGREEN;
STICKLINE(C>1.099*REF(C,1),C,O,3,0),COLORYELLOW;
AY2:=EMA(CLOSE,12) 10)) + IF(YYA6,10,(0 10))) + IF(YYA9,10,(0 – 10))) + IF(YYA11,10,(0 – 10)));
DSLX:=(CLOSE / INDEXC);
DSLX1:=MA(DSLX,5);
DSLX2:=MA(DSLX,10);
YYV1:=MA(VOL,5);
YYV2:=MA(VOL,10);
J1:=CONST(IF( YYAVX > 0,200,100));
J2:=CONST(IF( YYAVX > 0,00,100));
J3:=CONST(IF( YYAVX > 0,100,100));
ZGD3:=ZGD2;
ZDD3:=ZDD2;
ZGD4:=ZGD2;
情况1:=CONST(IF(((CROSS(YYAVX,1) AND (YYV1 >= YYV2)) AND (DSLX >= DSLX1)),1,0)),NODRAW;
情况2:=CONST(IF(((CROSS(YYAVX,1) AND (YYV1 < YYV2)) AND (DSLX >= DSLX1)),1,0));
情况3:=CONST(IF(((CROSS(YYAVX,1) AND (YYV1 > YYV2)) AND (DSLX < DSLX1)),1,0));
情况4:=CONST(IF(((CROSS(YYAVX,1) AND (YYV1 <= YYV2)) AND (DSLX < DSLX1)),1,0));
情况5:=CONST(IF(((CROSS(1,YYAVX) AND (YYV1 >= YYV2)) AND (DSLX >= DSLX1)),1,0));
情况6:=CONST(IF(((CROSS(1,YYAVX) AND (YYV1 < YYV2)) AND (DSLX >= DSLX1)),1,0));
情况7:=CONST(IF(((CROSS(1,YYAVX) AND (YYV1 >= YYV2)) AND (DSLX < DSLX1)),1,0));
情况8:=CONST(IF(((CROSS(1,YYAVX) AND (YYV1 < YYV2)) AND (DSLX < DSLX1)),1,0));
情况9:=CONST(IF(((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 >= YYV2)) AND (DSLX >= DSLX1)),1,0));
情况10:=CONST(IF(((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 < YYV2)) AND (DSLX >= DSLX1)),1,0));
情况11:=CONST(IF(((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 >= YYV2)) AND (DSLX < DSLX1)),1,0)),NODRAW;
情况12:=CONST(IF(((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 < YYV2)) AND (DSLX < DSLX1)),1,0));
情况13:=CONST(IF(((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 >= YYV2)) AND (DSLX >= DSLX1)),1,0));
情况14:=CONST(IF(((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 < YYV2)) AND (DSLX >= DSLX1)),1,0));
情况15:=CONST(IF(((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 >= YYV2)) AND (DSLX < DSLX1)),1,0));
情况16:=CONST(IF(((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 < YYV2)) AND (DSLX < DSLX1)),1,0));
大盘1:=CONST(IF((CROSS(YYAVX,1) AND (YYV1 >= YYV2)),1,0));
大盘2:=CONST(IF((CROSS(YYAVX,1) AND (YYV1 < YYV2)),1,0));
大盘3:=CONST(IF((CROSS(1,YYAVX) AND (YYV1 >= YYV2)),1,0));
大盘4:=CONST(IF((CROSS(1,YYAVX) AND (YYV1 < YYV2)),1,0));
大盘5:=CONST(IF((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 >= YYV2)),1,0));
大盘6:=CONST(IF((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 < YYV2)),1,0));
大盘7:=CONST(IF((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 >= YYV2)),1,0));
大盘8:=CONST(IF((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 < YYV2)),1,0));
TS1:=IF(情况1=1,0.06+0.06,0.06);
TS2:=IF(情况2=1,TS1+0.06,TS1);
TS3:=IF(情况3=1,TS2+0.06,TS2);
TS4:=IF(情况4=1,TS3+0.06,TS3);
TS5:=IF(情况5=1,TS4+0.06,TS4);
TS6:=IF(情况6=1,TS5+0.06,TS5);
TS7:=IF(情况7=1,TS6+0.06,TS6);
TS8:=IF(情况8=1,TS7+0.06,TS7);
TS9:=IF(情况9=1,TS8+0.06,TS8);
TS10:=IF(情况10=1,TS9+0.06,TS9);
TS11:=IF(情况11=1,TS10+0.06,TS10);
TS12:=IF(情况12=1,TS11+0.06,TS11);
TS13:=IF(情况13=1,TS12+0.06,TS12);
TS14:=IF(情况14=1,TS13+0.06,TS13);
TS15:=IF(情况15=1,TS14+0.06,TS14);
TS16:=IF(情况16=1,TS15+0.06,TS15);
DRAWTEXT_FIX(情况1=1 ,0.005,TS1,0,’【智能解盘】 量能理想,明显走强,中线参与,仓位在2/3左右’),COLORFF00FF;
DRAWTEXT_FIX(情况2=1 ,0.005,TS2,0,’【智能解盘】 势趋强,量能不足,短线进场,仓位在1/2左右’),COLORFF00FF;
DRAWTEXT_FIX(情况3=1 ,0.005,TS3,0,’【智能解盘】 量价良好,并没有明显走强,短线进场,仓位1/2左右。’),COLORFF00FF;
DRAWTEXT_FIX(情况4=1 ,0.005,TS4,0,’【智能解盘】 形态尚可,量能不足,未完全走强,短线参与,仓位1/3左右。’),COLORFF00FF;
DRAWTEXT_FIX(情况5=1 ,0.005,TS5,0,’【智能解盘】 形态变坏,走势尚可,重仓减大半,清仓者观望。’),COLOR00FFFF;
DRAWTEXT_FIX(情况6=1 ,0.005,TS6,0,’【智能解盘】 随大盘一起下跌,明显缩量走势,考虑大盘风险,减持或清仓。’),COLOR00FFFF;
DRAWTEXT_FIX(情况7=1 ,0.005,TS7,0,’【智能解盘】 该股放量下跌,走势明显偏弱,离场观望。’),COLORFFFFFF;
DRAWTEXT_FIX(情况8=1 ,0.005,TS8,0,’【智能解盘】 该股缩量下跌,走势偏弱,离场观望。’),COLORFFFF00;
DRAWTEXT_FIX(情况9=1 ,0.005,TS9,0,’【智能解盘】 该股形态良好,强势明显,量能充足,可以继续持有。’),COLOR00FFFF;
DRAWTEXT_FIX(情况10=1,0.005,TS10,0,’【智能解盘】 该股上行趋势不变,强势依然,但量能开始转弱,注意风险’),COLOR00FFFF;
DRAWTEXT_FIX(情况11=1,0.005,TS11,0,’【智能解盘】 该股仍然具备上涨潜力,但股性偏弱,可考虑减仓。’),COLORFFFFFF;
DRAWTEXT_FIX(情况12=1,0.005,TS12,0,’【智能解盘】 该股走势趋弱,量能不足,减持大部分筹码’),COLORFFFF00;
DRAWTEXT_FIX(情况13=1,0.005,TS13,0,’【智能解盘】 该股形态不佳,注意成交量的变化,但目前不适合参与。’),COLORFFFF00;
DRAWTEXT_FIX(情况14=1,0.005,TS14,0,’【智能解盘】 该股趋势不明,股价偏弱,注意量能变化,目前不宜参与。’),COLORFFFF00;
DRAWTEXT_FIX(情况15=1,0.005,TS15,0,’【智能解盘】 有走强迹象,但量能不足,趋势不明,不适合操作’),COLORFFFF00;
DRAWTEXT_FIX(情况16=1,0.005,TS16,0,’【智能解盘】 该股走势太弱,没有参与价值。’),COLORFFFFFF;
{板块地区概念}
所属板块:=STRCAT(‘【所属板块】’,STRCAT(STRCAT(STRCAT(‘ [行业]—’,HYBLOCK),STRCAT(‘ [地域]—’,DYBLOCK)),STRCAT(‘ [概念]—’,GNBLOCK)));
DRAWTEXT_FIX(ISLASTBAR,0.005,0.02,0,所属板块),COLOR00C0C0;
{均线标记}
DRAWTEXT(ISLASTBAR,MA5,’MA5′),COLORRED;
DRAWTEXT(ISLASTBAR,MA10,’MA10′),COLORCC66FF;
DRAWTEXT(ISLASTBAR,MA20,’MA20′),COLORFFCC66;
DRAWTEXT(ISLASTBAR,MA60,’MA60′),COLOR00FF99;
DRAWTEXT(ISLASTBAR,MA120,’MA120′),COLORGRAY;
DRAWTEXT(ISLASTBAR,MA250,’MA250′),COLORBLUE;

通达信不断创新高主图指标公式的选股公式


喜欢 (0)