通达信布林升降画线主图及选股指标公式

指标公式 5次浏览

通达信布林升降画线主图及选股指标公式

20192*STD(CLOSE,20),COLORGREEN,DOTLINE;
{画线}
AN:=10;
AA:=REF(H,AN)=HHV(H,2*AN+1);
QY:=BACKSET(AA,AN+1);
ACC:=FILTER(QY,AN) AND H=HHV(H,AN+1);
AAA1:=CROSS(BACKSET(BARSTATUS=2,SUMBARS(ACC,1)),0.5);
AB1:=CROSS(BACKSET(BARSTATUS=2,SUMBARS(ACC,2)),0.5);
升降趋势画线:DRAWLINE(AB1,H,AAA1,H,1),COLORFF8000,LINETHICK2;
HQSXG:=DRAWLINE(AB1,H,AAA1,H,1);
上突破:=CROSS(C,HQSXG) AND HQSXG>REF(HQSXG,1);
DRAWTEXT(上突破,H*1.01,’上突’),COLORFF8000;
下突破:=CROSS(C,HQSXG) AND HQSXG<REF(HQSXG,1);
DRAWTEXT(下突破,H*1.02,’下突’),COLORFF8000;

{
选股公式:

AN:=10;
AA:=REF(H,AN)=HHV(H,2*AN+1);
QY:=BACKSET(AA,AN+1);
ACC:=FILTER(QY,AN) AND H=HHV(H,AN+1);
AAA1:=CROSS(BACKSET(BARSTATUS=2,SUMBARS(ACC,1)),0.5);
AB1:=CROSS(BACKSET(BARSTATUS=2,SUMBARS(ACC,2)),0.5);
HQSXG:=DRAWLINE(AB1,H,AAA1,H,1);
上突破:=CROSS(C,HQSXG) AND HQSXG>REF(HQSXG,1);
下突破:=CROSS(C,HQSXG) AND HQSXG<REF(HQSXG,1);
XG:上突破 OR 下突破;
}

通达信布林升降画线主图及选股指标公式的选股公式


喜欢 (0)