通达信机构散户资金分时主图指标公式

20191)));
BC1:=IF(L=LLV(L,P2),C,DRAWNULL);
BC2:=CONST(BARSLAST(BC1=L))+1;
LOWER:=CONST(IF(BC2=1,C,REF(C,BC21))),DRAWNULL),POINTDOT,COLORLIGRAY;{近点}
LR2:=SLOPE(C,NOD+1);
LR3:=CONST(IF(MIN(TC2,BC2)=1,LR2,REF(LR2,MIN(TC2,BC2)FP);{高差};
DBL:=BARSLAST(BC1!=DRAWNULL)+1;
DBH:=BARSLAST(TC1!=DRAWNULL)+1;
BSP:=IF(BC2>TC2,DBL,DBH)LRL,MAX(BC2,TC2));
AT3:=CONST(BARSLAST(AT1LRL,AT3)));
ATL:=LRL+AT5;
UT1:=IF(BETWEEN(CURRBARSCOUNT,BC2,TC2) AND L<LRL,L,LRL);
UT2:=HHV(LRLUT1,REF(LRL10,ATL,CONST(REF(ATL,MIN(BC2,TC2)11)));{限制低}
中轨2:=IF(NP>FP,IF(LRL<=RH,LRL,DRAWNULL),IF(LRL>=RL,LRL,DRAWNULL)),COLORBLUE,,DOTLINE;
上轨2:=IF(NP>FP,IF(ATL<=RH,ATL,DRAWNULL),IF(ATL>=RL,ATL,DRAWNULL)),COLORMAGENTA,,DOTLINE;
下轨2:=IF(NP>FP,IF(UTL<=RH,UTL,DRAWNULL),IF(UTL>=RL,UTL,DRAWNULL)),COLOR00EE00,,DOTLINE;
T30:=IF(BARSSINCE(C>0)>=30,1,0);
{画线}
{IF(T30 AND 上轨2>REF(上轨2,2),上轨2,DRAWNULL),COLOR660066;
IF(T30 AND 中轨2>REF(中轨2,2),中轨2,DRAWNULL),COLOR660066;
IF(T30 AND 下轨2>REF(下轨2,2),下轨2,DRAWNULL),COLOR660066;
IF(T30 AND 上轨2<=REF(上轨2,2),上轨2,DRAWNULL),COLOR999900;
IF(T30 AND 中轨2<=REF(中轨2,2),中轨2,DRAWNULL),COLOR999900;
IF(T30 AND 下轨2<=REF(下轨2,2),下轨2,DRAWNULL),COLOR999900;}
X_1:=SUM(VOL*CLOSE,0)/SUM(VOL,0);
X_2:=EMA(X_1,50)/0.97;
X_3:=(X_1+X_2)/2;
DRAWBAND(X_2,RGB(100,30,0),X_3,0);{上轨填充色}
DRAWBAND(X_3,RGB(0,100,50),X_1,0);
上轨:X_2,COLORGREEN,LINETHICK2;
上轨变色:IF(X_2>REF(X_2,1),X_2,DRAWNULL),COLORRED,LINETHICK2;
中轨:X_3,COLORYELLOW;
下轨:X_1,COLORBLUE;
现价:CLOSE,COLORWHITE,LINETHICK2;
X_4:=CONST(REF(CLOSE,480));
X_5:=CONST(HHV(HIGH,480));
X_6:=CONST(LLV(LOW,480));
X_7:=EMA(CLOSE,30);
X_8:=EMA(CLOSE,900);
X_9:=MAX(X_4,X_5);
X_10:=MIN(X_4,X_6);
X_11:=X_9SUM(IF(C<REF(C,1),攻击量*V,0),FROMOPEN);
攻击流量:=攻击量A+攻击量B;
攻击比:=攻击流量/SUM(V,FROMOPEN)*100;
资金攻击度:=IF(攻击比>=0,(攻击比+50),100SUM(IF(C<REF(C,1),V,0),FROMOPEN);
资金出入:=资金流入+资金流出;
资金比:=资金出入/SUM(V,FROMOPEN)*100;
资金流量比:=IF(资金比>=0,(资金比+100)/2,100DATETODAY(REF(DATE,TOTALBARSCOUNTREF(WEEKDAY,1) OR TOTALBARSCOUNTDEA);
MACD2:=EMA(MACD1,2);
去除1:=STICKLINE(MACD1>=MACD2 AND MACD1>=0,DYNAINFO(3),MACD1+DYNAINFO(3),0,0);
去除2:=STICKLINE(MACD1<MACD2 AND MACD1>0,DYNAINFO(3),MACD1+DYNAINFO(3),0,0);
去除3:=STICKLINE(MACD1>=MACD2 AND MACD1<0,DYNAINFO(3),MACD1+DYNAINFO(3),0,0);
去除4:=STICKLINE(MACD1<MACD2 AND MACD1<0,DYNAINFO(3),MACD1+DYNAINFO(3),0,0);
XX:=SUM(AMOUNT,BARSCOUNT(CLOSE))/SUM(V*100,BARSCOUNT(CLOSE));
主力:=EXPMA(CLOSE/XX,20);大户:=EXPMA(CLOSE/XX,60);散户:=EXPMA(CLOSE/XX,120);
底:=1;1.02,NODRAW;高:=1.03;
DRAWTEXT(CROSS(主力,1.02),C*0.999,'A3;
散户买入:=A4;
散户卖出:=A5;
散户总买入:=A4A5))/A6,0)),'%');
DRAWTEXT_FIX(DD1=1,0.18,0.93,0,AAA1),COLORBLACK;
DRAWTEXT_FIX(DD1=1,0.18,1,0,AAA2),COLORBLACK;
DRAWTEXT_FIX(DD1=1,0.24,0.93,0,AAA3),COLORRED;
DRAWTEXT_FIX(DD1=1,0.24,1,0,AAA4),COLORRED;
DRAWRECTREL(0,870,300,910,RGB(0,250,50));{绿色}
DRAWRECTREL(0,875,CONST(机构买入比*300/100),905,RGB(200,50,0));
{DRAWRECTREL(0,880,CONST(机构买入比*300/100),900,RGB(255,210,0));}
DRAWRECTREL(147,870,153,910,RGB(0,75,200));{0轴小条}
{新加1XA_2;
阻力:XA_2+XA_3*7/8,COLORYELLOW,LINETHICK2;{撑压线}
支撑:XA_2+XA_3*0.5/8,COLORRED,LINETHICK2;
XA_4:=CLOSE;
DRAWICON(LONGCROSS(支撑,XA_4,2),支撑*0.998,1);{1号2号小图标}
DRAWICON(LONGCROSS(XA_4,阻力,2),XA_4,2);
{新加3REF(CLOSE,5))/REF(CLOSE,5);
BAB1:=STICKLINE(HJ_5>0,DYNAINFO(3),DYNAINFO(3)*(1+HJ_5),0.1,0);
BAB2:=STICKLINE(HJ_5<0,DYNAINFO(3),DYNAINFO(3)*(1+HJ_5),0.1,0);
HJ_6:=CLOSE/DYNAINFO(3);
HJ_7:=FILTER(HJ_5>0.015 AND HJ_5>REF(HJ_5,1)*2 AND VOL>REF(VOL,1)*2 AND CLOSE>REF(CLOSE,1) OR HJ_5>0.025,240);
DRAWICON(HJ_7 AND HJ_6<1.06 AND CLOSE>DYNAINFO(3),C,23);{东风小图标}
DRAWICON(HJ_7 AND HJ_6<1.06 AND CLOSE>DYNAINFO(3),C,1);
DRAWTEXT(HJ_7 AND HJ_6<1.06 AND CLOSE>DYNAINFO(3),C,' 东风来了')COLORYELLOW;
S木子0:=REF(CLOSE,1);
S木子1:=REF(MAX(HIGH,S木子0),1);
S木子2:=REF(MIN(LOW,S木子0),1);
MACS:=(MA((((S木子1 (木子8 / 100))));
木子12:=((REF(SUM(木子10,0),1) = 0) AND (SUM(木子10,0) = 1));
木子13:=((REF(SUM(木子11,0),1) = 0) AND (SUM(木子11,0) = 1));
木子14:=(SUM(木子12,0) * CROSS(COUNT((CLOSE < REF(CLOSE,1)),BARSLAST(木子12)),0.5));
木子15:=(SUM(木子13,0) * CROSS(COUNT((CLOSE > REF(CLOSE,1)),BARSLAST(木子13)),0.5));
CS1:=CONST(SUM(IF(木子14,REF(CLOSE,1),DRAWNULL),0)),LINETHICK2,COLORGREEN;
CB1:=CONST(SUM(IF(木子15,REF(CLOSE,1),DRAWNULL),0)),LINETHICK2,COLORMAGENTA;
木子18:=CROSS(SUM((木子10 AND (CLOSE > (CS1 * (1 + (木子9 / 100))))),0),0.5);
木子19:=CROSS(SUM((木子11 AND (CLOSE < (CB1 * (1 EMA(CLOSE,CJFSP))*10;
神:=EMA(财,CJFSM1);
BTJ1:=(CLOSECJFSJJ)/CJFSJJ<(CJFSJJ)/CJFSJJ>0.005;
STJ01:=控盘<REF(控盘,1) AND 控盘>0.5;
STJ02:=控盘>0;
BTJ2:=控盘>REF(控盘,1) AND 控盘<(0.1);
STJ31:=CROSS(神,财);
STJ32:=CROSS(神,财) AND 财>1.618;
BTJ81:=FILTER(BTJ1 AND BTJ2 AND BTJ3,13);
BTJ82:=FILTER(BTJ12 AND BTJ22 AND BTJ32,13);
有庄:=IF(BTJ81,1,0);
STJ81:=FILTER(STJ1 AND STJ01 AND STJ31,13);
VAR11:=(CLOSELLV(LOW,43))*100;
VAR33:=SMA(VAR22,2,1);
CJFSNN:=SMA(VAR33,2,1);
CJFSMM:=ABS(VAR11);
买:=STICKLINE(CROSS(CJFSNN,CJFSMM),3,20,2,0);
可买:IF(买,上轨,支撑位)COLORYELLOW,LINETHICK2;
必买:IF(BTJ81,上轨,支撑位)COLORYELLOW,LINETHICK2;
VAR3:=3*SMA((CLOSE2*SMA(SMA((CLOSE10;
VAR4:=(趋势-REF(趋势,1))/REF(趋势,1)*100;
VAR6:=FILTER(趋势>=90 AND VAR4,10);
卖1:=IF(VAR6,5,0);
卖2:=IF(STJ81,3,0),COLORLICYAN;
STJ82:=FILTER(STJ02 AND STJ32,13);
STJ83:=STJ81 AND STJ82;
清仓:=IF(STJ83,4,0),COLORRED;
DRAWICON(可买 ,上轨,23);

通达信机构散户资金分时主图指标公式的选股公式