通达信雪无痕主图指标公式

2019L)+(CL)+(C(GJ14,COLORBBBBBB,NODRAW;
离场:=IF(红持股,JRL,DRAWNULL);
明离场价:=离场,COLORFF99FF,NODRAW;
今离场价:=REF(离场,1)COLOR0000FF,NODRAW;
进:=IF(阴观望,JRH,DRAWNULL);
明进场价:=进,COLOR33AACC,NODRAW;
今进场价:=REF(明进场价,1),COLOR00FF00,NODRAW;
Q1:=CONST(IF( 短买春,0,IF(秋离场,150,IF(红持股,150,IF(急速超跌关注,150,100))))),NODRAW;
Q2:=CONST(IF( 短买春,100,IF(秋离场,100,IF(红持股,0,IF( 急速超跌关注,150,100))))),NODRAW;
Q3:=CONST(IF( 短买春,0,IF(秋离场,20,IF(红持股,70,IF( 急速超跌关注,150,100))))),NODRAW;
DRAWBAND(龙,RGB(Q1,Q2,Q3),凤,DRAWNULL);
大雪:=MA((((HIGH + LOW) + CLOSE) / 3),8);
无痕:=MA((((HIGH + LOW) + CLOSE) / 3),21);
VAR111:=EMA(((OPEN + CLOSE) / 2),26);
VAR222:=IF(C<200 , MA(COST(30),3),2300),NODRAW;
天下有雪:=IF(C<200 ,MA(COST(50),3),2300);
严冬:=ISLASTBAR AND (VAR4 > 0.1),COLORFFFFFF,NODRAW;
早春:=ISLASTBAR AND (((((VAR4 < 天下有雪) AND (VAR4 > 无痕))
OR ((VAR4 < VAR5) AND (VAR4 > 无痕))) OR ((VAR4 > 无痕)
AND (VAR111 > 无痕)))),COLOR00FF00,NODRAW;
初夏:=ISLASTBAR AND ((((((VAR4 > 天下有雪) AND (VAR4 > VAR111))
AND (VAR4 > VAR5)) AND (VAR222 > REF(VAR222,1))) OR ((((VAR4 > VAR222)
AND (VAR4 > VAR111)) AND (VAR4 > VAR5)) AND (VAR222 > REF(VAR222,1))))),
COLOR0000FF,NODRAW;
深秋:=ISLASTBAR AND (((((VAR4 > VAR6) AND (VAR4 > VAR3)) AND (大雪 > 无痕))
AND (VAR111 > REF(VAR111,1)))),COLOR00FFFF,NODRAW;
SAAA:=(3*C+H+L+O)/6;
SVAR1:=(8*SAAA+7*REF(SAAA,1)+6*REF(SAAA,2)
+5*REF(SAAA,3)+4*REF(SAAA,4)+3*REF(SAAA,5)+2*REF(SAAA,6)+REF(SAAA,8))/36;
SVAR2:=(HHV(SVAR1,5)+HHV(SVAR1,10)+HHV(SVAR1,20))/3;
SVAR3:=(LLV(SVAR1,5)+LLV(SVAR1,10)+LLV(SVAR1,20))/3;
SVAR4:=(HHV(SVAR2,5)+HHV(SVAR2,10)+HHV(SVAR2,20))/3;
SVAR5:=(LLV(SVAR3,5)+LLV(SVAR3,10)+LLV(SVAR3,20))/3;
SVAR6:=(LLV(SVAR1,2)+LLV(SVAR1,4)+LLV(SVAR1,6))/3;
ZGD:=HHV(REF((C*21)); DDCS13:=CONST(REF(L,DDCS11));
XG1:=BACKSET(ISLASTBAR,GDCS1); XD1:=BACKSET(ISLASTBAR,DDCS1);
XG2:=BACKSET(ISLASTBAR,DINGBUTS1); XD2:=BACKSET(ISLASTBAR,DDTS2);
XDD:=IF(DDCS13<=DDCS23,XD1,XD2);
M:=INTPART(3*N/5);
AAA:=REF(H,M)=HHV(H,2*M+1);
QYY:=BACKSET(AAA,M+1);
CCC:=FILTER(QYY,M) AND H=HHV(H,M+1);
DDDD:=BARSLAST(CCC),NODRAW;
GDTSS:=IF(CCC,CURRBARSCOUNT,0);
DINGBUTSS:=IF(DDDD,REF(GDTSS,DDDD),GDTSS);
GDCS11:=CONST(DINGBUTSS);
DINGBUTS11:=REF(DINGBUTSS,DDDD+1);
GDCS22:=CONST(DINGBUTS11);
AA11:=REF(L,M)=LLV(L,2*M+1);
QY11:=BACKSET(AA11,M+1);
CC11:=FILTER(QY11,M) AND L=LLV(L,M+1);
DD11:=BARSLAST(CC11);
DDTSS:=IF(CC11,CURRBARSCOUNT,0);
DDTS11:=IF(DD11,REF(DDTSS,DD11),DDTSS);
DDCS11:=CONST(DDTS11);
DDTS22:=REF(DDTS11,DD11+1);
DDCS22:=CONST(DDTS22);
HH1:= REF(H,GDCS11),NODRAW;
HH22:= REF(H,GDCS221)),MAX(REF(H,GDCS111),REF(L,DDCS21))),NODRAW;
DX1:=(REF(H,GDCS11))/(GDCS21))+DX1*GDCS1)<ZDD2*0.98,0,1);
DX2:=(REF(H,GDCS111))/(GDCS221))+DX2*DDCS11)<ZDD2*0.98,0,1);
LX1:=(REF(L,DDCS11))/(DDCS21))+LX1*DDCS1)>ZGD2*1.02,0,1);
LX2:=(REF(L,DDCS111))/(DDCS221))+LX2*DDCS11)>ZGD2*1.02,0,1);
高压力:DRAWLINE(K=0 AND CURRBARSCOUNT=GDCS2,H,CURRBARSCOUNT=GDCS1,H,DDX1),COLORYELLOW,LINETHICK1;
低支撑:DRAWLINE(K=0 AND CURRBARSCOUNT=DDCS2,L,CURRBARSCOUNT=DDCS1,L,LLX1),COLORYELLOW,LINETHICK1;
DRAWLINE(K=0 AND CURRBARSCOUNT=GDCS22 ,H,CURRBARSCOUNT=GDCS11,H,DDDX1),COLORWHITE,LINETHICK1;
DRAWLINE(K=0 AND CURRBARSCOUNT=DDCS22 ,L,CURRBARSCOUNT=DDCS11,L,LLLX1),COLORWHITE,LINETHICK1;
CCA:=ABS((2*CLOSE+HIGH+LOW)/4 LLV(LOW,13)) / (HHV(HIGH,13) LLV(LOW,55)) / (HHV(HIGH,55) REF(CLOSE,1)),0),7,1) / SMA(ABS((CLOSE MA21)),6,1)) * 100);
卖出2:=CROSS(84,ZX),COLORFF00FF;
卖出3:=CROSS(90,RSI);
卖出:=卖出1 OR 卖出2 OR 卖出3;
DRAWICON(卖出,(HIGH * 1.002),15);
{买入}
QQ2:=(CLOSE2*QQ4,COLORWHITE,LINETHICK3;
趋势线:=EMA(QQ3, 3),COLORRED,LINETHICK3;
金叉:= CROSS(长趋势,趋势线);
AAAA1:=AMOUNT/V;
BBB1:=L<AAAA1*0.9;
CCC1:=(CMA(CLOSE,13)/3);
VAR2:=( MA((CLOSELLV(LOW,28))*100;
VVAR4:=SMA(VVAR3,4,1);
MMA:=EMA(VAR2,12)*0.7;
MMB:=EMA(VAR2,3);
快到底:=IF(LLV(MMB EMA(CLOSE,26))*100;
DEA:=EMA(DIFF,9);
MACD:= 2*(DIFFAVAR4)*100,4)*AVAR3;
庄家:= EMA(0.667*REF(散户,1)+0.333*散户,2)*AVAR3;
AA05:=MA(C,5),COLOR0099CC;
五日乖离率:=(CREF(AA05,1))/REF(AA05,1),3)*100,3,1);
加速度5:=EMA((速度5AA30)/AA30*100;
加仓:=FILTER(COUNT(CROSS(BB05,30),5)>=1 AND
AA05>REF(AA05,1) AND 三拾日乖离率>REF(三拾日乖离率,1) AND
AA10>REF(AA10,1)
AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1) ,10) ;
MV3:=EMA(V,3);
MV3角度:=ATAN((MV3/REF(MV3,1)1)*100)*180/3.1416;
MA5角度:=ATAN((MA5/REF(MA5,1)1)*100)*180/3.1416;
强弱度:=(MV3角度+MA3角度+MV5角度+MA5角度+MV10角度+MA10角度)/6,COLORFFFFFF;
QBD:=CROSS(强弱度,50) AND COUNT(强弱度>50,7)<=3;
启爆点:=IF(K=0 AND QBD AND COUNT(QBD,4)=1,50,0),COLOR00FFFF;
半月相对价位:=(CREF(HIGH,1);
LD :=REF(LOW,1)MA(DMM,3))*1,3)*100+50,COLORFFFFFF;
DRAWICON(CROSS(AK,AD) AND 启爆点 AND 福缘,L*0.99 ,9);
DRAWICON(加仓,L*0.99,23);
DRAWICON(老鼠仓 OR 金叉,(LOW - (LOW * 0.01)),1);
DRAWTEXT(秋离场,HHV(H,3),'→→→→'),COLORFF99FF;
DRAWTEXT(短买春,LLV(L,3),'←←←←'),COLOR00FF00;
{严冬:}STICKLINE((VAR4 > 0.1),HIGH,LOW,0,0),COLORFFFFFF;
{早春:}STICKLINE(((((VAR4 < 天下有雪) AND (VAR4 > 无痕))
OR ((VAR4 < VAR5) AND (VAR4 > 无痕))) OR ((VAR4 > 无痕)
AND (VAR111 > 无痕))),HIGH,LOW,0,0),COLOR00FF00;
{初夏:}STICKLINE((((((VAR4 > 天下有雪) AND (VAR4 > VAR111))
AND (VAR4 > VAR5)) AND (VAR222 > REF(VAR222,1))) OR ((((VAR4 > VAR222)
AND (VAR4 > VAR111)) AND (VAR4 > VAR5)) AND (VAR222 > REF(VAR222,1)))),
HIGH,LOW,0,0),COLOR0000FF;
{深秋:}STICKLINE(((((VAR4 > VAR6) AND (VAR4 > VAR3)) AND (大雪 > 无痕))
AND (VAR111 > REF(VAR111,1))),HIGH,LOW,0,0),COLOR00FFFF;
STICKLINE(((VAR4 > 0.1) AND (CLOSE < OPEN)),OPEN,CLOSE,2.8,0),COLORCCCCCC;
STICKLINE(((VAR4 > 0.1) AND (CLOSE >= OPEN)),OPEN,CLOSE,2.8,1),COLORCCCCCC;
STICKLINE(((VAR4 > 0.1) AND (CLOSE >= OPEN)),OPEN,OPEN+(CLOSE-OPEN)/3,2.8,0),COLORFFFFFF;
STICKLINE((((((VAR4 < 天下有雪) AND (VAR4 > 无痕)) AND (CLOSE < OPEN))
OR (((VAR4 < VAR5) AND (VAR4 > 无痕)) AND (CLOSE < OPEN)))
OR (((VAR4 > 无痕) AND (VAR111 > 无痕)) AND (CLOSE < OPEN))),
OPEN,CLOSE,2.8,0),COLOR00FF00;
STICKLINE((((((VAR4 < 天下有雪) AND (VAR4 > 无痕)) AND (CLOSE > OPEN))
OR (((VAR4 < VAR5) AND (VAR4 > 无痕)) AND (CLOSE > OPEN)))
OR (((VAR4 > 无痕) AND (VAR111 > 无痕)) AND (CLOSE >= OPEN)))
,OPEN,CLOSE,2.8,1),COLOR00FF00;
STICKLINE(((((((VAR4 > 天下有雪) AND (VAR4 > VAR111)) AND (VAR4 > VAR5))
AND (VAR222 > REF(VAR222,1))) AND (CLOSE < OPEN)) OR (((((VAR4 > VAR222)
AND (VAR4 > VAR111)) AND (VAR4 > VAR5)) AND (VAR222 > REF(VAR222,2)))
AND (CLOSE < OPEN))),OPEN,CLOSE,2.8,0),COLOR0000FF;
STICKLINE(((((((VAR4 > 天下有雪) AND (VAR4 > VAR111)) AND (VAR4 > VAR5))
AND (VAR222 > REF(VAR222,1))) AND (CLOSE > OPEN)) OR (((((VAR4 > VAR222)
AND (VAR4 > VAR111)) AND (VAR4 > VAR5)) AND (VAR222 > REF(VAR222,1)))
AND (CLOSE >= OPEN))),OPEN,CLOSE,2.8,1),COLOR0000FF;
STICKLINE((((((VAR4 > VAR6) AND (VAR4 > VAR3)) AND (大雪 > 无痕))
AND (VAR111 > REF(VAR111,1))) AND (CLOSE < OPEN)),OPEN,CLOSE,2.8,0)
,COLOR00FFFF;
STICKLINE((((((VAR4 > VAR6) AND (VAR4 > VAR3)) AND (大雪 > 无痕))
AND (VAR111 > REF(VAR111,1))) AND (CLOSE >= OPEN)),OPEN,CLOSE,2.8,1)
,COLOR00FFFF;

通达信雪无痕主图指标公式的选股公式