通达信操作止损线主图指标公式

(HIGHLOW)*0.5,NODRAW;
三二:=HIGH(CLOSECLOSE)/3),NODRAW,COLORGREEN;
实体腰线:OPEN+(CLOSECLOSE)/3),NODRAW,COLORGREEN;
现价:IF(CURRBARSCOUNT<60,CONST(REF(C,0)),DRAWNULL),COLORGRAY,DOTLINE;
{1),COLOR00C0C0;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
{}
HJ_1:=CLOSE/REF(CLOSE,1)>=1.099 AND CLOSE=HIGH;
HJ_2:=CLOSE/REF(CLOSE,1)<0.91 AND CLOSE=LOW;
HJ_3:=IF(NAMELIKE(1),1,0) OR IF(NAMELIKE(2),1,0);
HJ_4:=CLOSE/REF(CLOSE,1)>1.0491 AND CLOSE=HIGH;
HJ_5:=HJ_3 AND HJ_4;
HJ_6:=CLOSE/REF(CLOSE,1)<0.951 AND CLOSE=LOW;
HJ_7:=HJ_3 AND HJ_6;
HJ_8:=MA(VOL,5);
HJ_9:=MA(VOL,10);
HJ_10:=MA(VOL,20);
HJ_11:=COUNT(MA(CLOSE,10)>MA(CLOSE,5),10)=10 AND COUNT(HJ_9>HJ_8,10)=10;
HJ_12:=NOT(HJ_11);
HJ_13:=COUNT(MA(CLOSE,20)>MA(CLOSE,10),18)=18 AND COUNT(HJ_10>HJ_9,18)=18;
HJ_14:=NOT(HJ_13);
HJ_15:=COUNT(MA(CLOSE,20)>MA(CLOSE,10),30)=30;
HJ_16:=NOT(HJ_15);
HJ_17:=COUNT(MA(CLOSE,60)>MA(CLOSE,20),30)=30 AND MA(CLOSE,20)>MA(CLOSE,10);
HJ_18:=NOT(HJ_17);
HJ_19:=COUNT(MA(CLOSE,20)>MA(CLOSE,10) AND MA(CLOSE,10)>MA(CLOSE,5),20)>15 AND COUNT(MA(CLOSE,5)>=MA(CLOSE,10),3)<3;
HJ_20:=NOT(HJ_19);
HJ_21:=COUNT(MA(CLOSE,60)>MA(CLOSE,20) AND MA(CLOSE,20)>MA(CLOSE,10) AND MA(CLOSE,10)>MA(CLOSE,5),5)=5;
HJ_22:=NOT(HJ_21);
HJ_23:=HJ_12 AND HJ_14 AND HJ_16 AND HJ_18 AND HJ_20 AND HJ_22;
HJ_24:=VOL>REF(HJ_9,1) AND VOL>REF(HJ_10,1);
HJ_26:=IF(LOW>REF(HIGH,1),MAX(REF(CLOSE,1),REF(OPEN,1)),OPEN);
HJ_27:=CLOSE>OPEN AND CLOSE>REF(OPEN,1);
HJ_28:=REF(CLOSE,1)<=REF(OPEN,1);
HJ_29:=REF(CLOSE,1)>REF(OPEN,1) AND CLOSEREF(DYNAINFO(37),1))/DYNAINFO(37)<0.2;
HJ_42:=HJ_38 OR HJ_39 OR HJ_40 OR HJ_41;
HJ_43:=HJ_26<MA(CLOSE,5) AND HJ_26<MA(CLOSE,10) AND CLOSE>MA(CLOSE,5) AND CLOSE>MA(CLOSE,10);
HJ_44:=HJ_26<MA(CLOSE,5) AND HJ_26<MA(CLOSE,20) AND CLOSE>MA(CLOSE,5) AND CLOSE>MA(CLOSE,20);
HJ_45:=HJ_26<MA(CLOSE,10) AND HJ_26<MA(CLOSE,20) AND CLOSE>MA(CLOSE,10) AND CLOSE>MA(CLOSE,20);
HJ_46:=HJ_43 OR HJ_44 OR HJ_45;
HJ_47:=HJ_26<MA(CLOSE,20) AND HJ_26<MA(CLOSE,60) AND CLOSE>MA(CLOSE,20) AND CLOSE>MA(CLOSE,60);
HJ_48:=HJ_26<MA(CLOSE,20) AND HJ_26<MA(CLOSE,120) AND CLOSE>MA(CLOSE,20) AND CLOSE>MA(CLOSE,120);
HJ_49:=HJ_26<MA(CLOSE,60) AND HJ_26<MA(CLOSE,120) AND CLOSE>MA(CLOSE,60) AND CLOSE>MA(CLOSE,120);
HJ_50:=HJ_47 OR HJ_48 OR HJ_49;
HJ_51:=HJ_26<MA(CLOSE,60) AND HJ_26<MA(CLOSE,250) AND CLOSE>MA(CLOSE,60) AND CLOSE>MA(CLOSE,250);
HJ_52:=HJ_26<MA(CLOSE,60) AND HJ_26<MA(CLOSE,120) AND CLOSE>MA(CLOSE,60) AND CLOSE>MA(CLOSE,120);
HJ_53:=HJ_26<MA(CLOSE,10) AND HJ_26<MA(CLOSE,120) AND CLOSE>MA(CLOSE,10) AND CLOSE>MA(CLOSE,120);
HJ_54:=HJ_51 OR HJ_52 OR HJ_53;
HJ_55:=HJ_26<MA(CLOSE,5) AND HJ_26<MA(CLOSE,60) AND CLOSE>MA(CLOSE,5) AND CLOSE>MA(CLOSE,60);
HJ_56:=HJ_26<MA(CLOSE,10) AND HJ_26<MA(CLOSE,60) AND CLOSE>MA(CLOSE,10) AND CLOSE>MA(CLOSE,60);
HJ_57:=HJ_26<MA(CLOSE,20) AND HJ_26<MA(CLOSE,250) AND CLOSE>MA(CLOSE,20) AND CLOSE>MA(CLOSE,250);
HJ_58:=HJ_55 OR HJ_56 OR HJ_57;
HJ_59:=HJ_26<MA(CLOSE,5) AND HJ_26<MA(CLOSE,120) AND CLOSE>MA(CLOSE,5) AND CLOSE>MA(CLOSE,120);
HJ_60:=HJ_26<MA(CLOSE,10) AND HJ_26<MA(CLOSE,250) AND CLOSE>MA(CLOSE,250) AND CLOSE>MA(CLOSE,250);
HJ_61:=HJ_26<MA(CLOSE,5) AND HJ_26<MA(CLOSE,250) AND CLOSE>MA(CLOSE,5) AND CLOSE>MA(CLOSE,250);
HJ_62:=HJ_59 OR HJ_60 OR HJ_61;
HJ_63:=HJ_46 OR HJ_50 OR HJ_54 OR HJ_58 OR HJ_62;
HJ_64:=HJ_63 AND HJ_42 AND HJ_34 AND HJ_23 AND HJ_24 ;
HJ_65:=VOL>=HHV(VOL,120) AND HJ_1 AND CLOSE>OPEN;
HJ_66:=VOL>=HHV(VOL,120) AND NOT(HJ_1) AND CLOSE>OPEN;
HJ_67:=VOL>=HHV(VOL,120) AND HJ_2 AND CLOSE<OPEN;
HJ_68:=VOL>=HHV(VOL,120) AND NOT(HJ_2) AND CLOSE<OPEN;
STICKLINE(HJ_1 ,OPEN,CLOSE,3,0),COLORYELLOW;
STICKLINE(HJ_2 ,OPEN,CLOSE,3,0),COLORGREEN;
STICKLINE(HJ_65 ,OPEN,OPEN+(CLOSE(OPENCLOSE)*0.5,CLOSE,3,0),COLORGREEN;
STICKLINE(HJ_68 ,OPEN,CLOSE,3,0),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR ,0,0,0,HYBLOCK);
DRAWTEXT_FIX(ISLASTBAR ,0.05,0,0,DYBLOCK);
DRAWTEXT_FIX(ISLASTBAR ,0.1,0,0,GNBLOCK);
{1),COLORLICYAN;
STICKLINE((A01 OR A02) AND BETWEEN(CLOSE,1,1000),实三二,实三二,2,-}
找顶线:DRAWLINE(A01,实体腰线,REF(A01,1),REF(实体腰线,1),1),DOTLINE,COLORLIMAGENTA;
找底线:DRAWLINE(A02,实体腰线,REF(A02,1),REF(实体腰线,1),1),DOTLINE,COLORLICYAN;
XG:CROSS(C,找顶线) AND 找顶线>0 ,NODRAW;
XG1:CROSS(C,找底线) AND 找底线>0 ,NODRAW;
DRAWICON(XG,LOW,1);
DRAWICON(XG1,LOW,30);

通达信操作止损线主图指标公式的选股公式