通达信行业分析加强版指标公式

REF(INDEC,1))*100/REF(INDEC,1);
A:=STRCAT(板块,STRCAT(':',CON2STR(INDEC,2)));
B:=STRCAT(STRCAT('指数涨跌:',CON2STR(指数涨幅,2)),' %');
DRAWTEXT_FIX(ISLASTBAR,0,0,0,A),COLOR0055FF;
DRAWTEXT_FIX(ISLASTBAR,0.1,0,0,B),COLOR0055FF;
沪A涨家数:="999999$ADVANCE",COLORRED,NODRAW;
沪A跌家数:="999999$DECLINE",COLORGREEN,NODRAW;
深A涨家数:="399001$ADVANCE",COLORRED,NODRAW;
深A跌家数:="399001$DECLINE",COLORGREEN,NODRAW;
中小涨家数:="399005$ADVANCE",COLORRED,NODRAW;
中小跌家数:="399005$DECLINE",COLORGREEN,NODRAW;
创业涨家数:="399006$ADVANCE",COLORRED,NODRAW;
创业跌家数:="399006$DECLINE",COLORGREEN,NODRAW;
上涨总家数:=沪A涨家数+深A涨家数,COLORRED,NODRAW;
下跌总家数:=沪A跌家数+深A跌家数,COLORGREEN,NODRAW;
BBB1:=STRCAT('沪A涨家数: ',CON2STR(沪A涨家数,0));
DRAWTEXT_FIX(ISLASTBAR,0,0.06,0,BBB1),COLORRED;
BBB2:=STRCAT('沪A跌家数: ',CON2STR(沪A跌家数,0));
DRAWTEXT_FIX(ISLASTBAR,0,0.12,0,BBB2),COLORGREEN;
BBB3:=STRCAT('深A涨家数: ',CON2STR(深A涨家数,0));
DRAWTEXT_FIX(ISLASTBAR,0.1,0.06,0,BBB3),COLORRED;
BBB4:=STRCAT('深A跌家数: ',CON2STR(深A跌家数,0));
DRAWTEXT_FIX(ISLASTBAR,0.1,0.12,0,BBB4),COLORGREEN;
BBB5:=STRCAT('中小涨家数: ',CON2STR(中小涨家数,0));
DRAWTEXT_FIX(ISLASTBAR,0.2,0.06,0,BBB5),COLORRED;
BBB6:=STRCAT('中小跌家数:',CON2STR(中小跌家数,0));
DRAWTEXT_FIX(ISLASTBAR,0.2,0.12,0,BBB6),COLORGREEN;
BBB7:=STRCAT('创业涨家数: ',CON2STR(创业涨家数,0));
DRAWTEXT_FIX(ISLASTBAR,0.3,0.06,0,BBB7),COLORRED;
BBB8:=STRCAT('创业跌家数: ',CON2STR(创业跌家数,0));
DRAWTEXT_FIX(ISLASTBAR,0.3,0.12,0,BBB8),COLORGREEN;
上涨总家数比:=上涨总家数/(上涨总家数+下跌总家数)*100,COLORRED,NODRAW;
下跌总家数比:=下跌总家数/(上涨总家数+下跌总家数)*100,COLORGREEN,NODRAW;
沪A上涨家数比:=沪A涨家数/(沪A涨家数+沪A跌家数)*100,COLORRED,NODRAW;
沪A下跌家数比:=沪A跌家数/(沪A涨家数+沪A跌家数)*100,COLORGREEN,NODRAW;
深A上涨家数比:=深A涨家数/(深A涨家数+深A跌家数)*100,COLORRED,NODRAW;
深A下跌家数比:=深A跌家数/(深A涨家数+深A跌家数)*100,COLORGREEN,NODRAW;
中小上涨家数比:=中小涨家数/(中小涨家数+中小跌家数)*100,COLORRED,NODRAW;
中小下跌家数比:=中小跌家数/(中小涨家数+中小跌家数)*100,COLORGREEN,NODRAW;
创业上涨家数比:=创业涨家数/(创业涨家数+创业跌家数)*100,COLORRED,NODRAW;
创业下跌家数比:=创业跌家数/(创业涨家数+创业跌家数)*100,COLORGREEN,NODRAW;
AAA1:=STRCAT(STRCAT('上涨总家数比 ',CON2STR(上涨总家数比,0)),' %');
DRAWTEXT_FIX(ISLASTBAR,0.4,0.06,0,AAA1),COLORRED;
AAA2:=STRCAT(STRCAT('下跌总家数比 ',CON2STR(下跌总家数比,0)),' %');
DRAWTEXT_FIX(ISLASTBAR,0.4,0.12,0,AAA2),COLORGREEN;
AAA3:=STRCAT(STRCAT('沪A上涨家数比 ',CON2STR(沪A上涨家数比,0)),' %');
DRAWTEXT_FIX(ISLASTBAR,0.5,0.06,0,AAA3),COLORRED;
AAA4:=STRCAT(STRCAT('沪A下跌家数比 ',CON2STR(沪A下跌家数比,0)),' %');
DRAWTEXT_FIX(ISLASTBAR,0.5,0.12,0,AAA4),COLORGREEN;
AAA5:=STRCAT(STRCAT('深A上涨家数比 ',CON2STR(深A上涨家数比,0)),' %');
DRAWTEXT_FIX(ISLASTBAR,0.6,0.06,0,AAA5),COLORRED;
AAA6:=STRCAT(STRCAT('深A下跌家数比 ',CON2STR(深A下跌家数比,0)),' %');
DRAWTEXT_FIX(ISLASTBAR,0.6,0.12,0,AAA6),COLORGREEN;
AAA7:=STRCAT(STRCAT('中小上涨家数比 ',CON2STR(中小上涨家数比,0)),' %');
DRAWTEXT_FIX(ISLASTBAR,0.7,0.06,0,AAA7),COLORRED;
AAA8:=STRCAT(STRCAT('中小下跌家数比 ',CON2STR(中小下跌家数比,0)),' %');
DRAWTEXT_FIX(ISLASTBAR,0.7,0.12,0,AAA8),COLORGREEN;
AAA9:=STRCAT(STRCAT('创业上涨家数比 ',CON2STR(创业上涨家数比,0)),' %');
DRAWTEXT_FIX(ISLASTBAR,0.8,0.06,0,AAA9),COLORRED;
AAA10:=STRCAT(STRCAT('创业下跌家数比 ',CON2STR(创业下跌家数比,0)),' %');
DRAWTEXT_FIX(ISLASTBAR,0.8,0.12,0,AAA10),COLORGREEN;
CCC:=HY_INDEXC;
OOO:=HY_INDEXO;
LLL:=HY_INDEXL;
HHH:=HY_INDEXH;
DRAWKLINE(HHH,OOO,LLL,CCC);
MA5:MA(CCC,5);
MA10:MA(CCC,10);
MA20:MA(CCC,20);
MA60:MA(CCC,60);
上涨:=VARCAT('行业上涨:',VAR2STR(HY_INDEXADV,0));
下跌:=VARCAT('行业下跌:',VAR2STR(HY_INDEXDEC,0));
DRAWTEXT_FIX(ISLASTBAR,0.7,0,0,上涨),COLORMAGENTA;
DRAWTEXT_FIX(ISLASTBAR,0.8,0,0,下跌),COLORYELLOW;
ZF:=(CMA(CLOSE,30))/MA(CLOSE,30)*100,COLORWHITE;
行业强弱:=(HY_INDEXCREF("880301$C",1))/REF("880301$C",1)*100;
电力A:=("880305$C"REF("880318$C",1))/REF("880318$C",1)*100;
有色A:=("880324$C"REF("880335$C",1))/REF("880335$C",1)*100;
建材A:=("880344$C"REF("880351$C",1))/REF("880351$C",1)*100;
日用化工A:=("880355$C"REF("880367$C",1))/REF("880367$C",1)*100;
食品饮料A:=("880372$C"REF("880387$C",1))/REF("880387$C",1)*100;
汽车类A:=("880390$C"REF("880399$C",1))/REF("880399$C",1)*100;
医药A:=("880400$C"REF("880414$C",1))/REF("880414$C",1)*100;
传媒娱乐A:=("880418$C"REF("880422$C",1))/REF("880422$C",1)*100;
酒店餐饮A:=("880423$C"REF("880430$C",1))/REF("880430$C",1)*100;
船舶A:=("880431$C"REF("880437$C",1))/REF("880437$C",1)*100;
工业机械A:=("880440$C"REF("880447$C",1))/REF("880447$C",1)*100;
电器仪表A:=("880448$C"REF("880453$C",1))/REF("880453$C",1)*100;
水务A:=("880454$C"REF("880456$C",1))/REF("880456$C",1)*100;
运输服务A:=("880459$C"REF("880465$C",1))/REF("880465$C",1)*100;
银行类A:=("880471$C"REF("880473$C",1))/REF("880473$C",1)*100;
多元金融A:=("880474$C"REF("880482$C",1))/REF("880482$C",1)*100;
电脑设备A:=("880489$C"REF("880491$C",1))/REF("880491$C",1)*100;
元器件A:=("880492$C"REF("880494$C",1))/REF("880494$C",1)*100;
综合类A:=("880497$C"电力A=0 OR ZZDZ有色A=0 OR ZZDZ建材A=0 OR ZZDZ船舶A=0 OR ZZDZ医药A=0,614,IF(ZZDZ证券类A=0 OR ZZDZ半导体A=0 OR ZZDZ综合类A=0,627,643)));
DRAWTEXT_FIX(ISLASTBAR,0.9,0,0,IF(ZZDZ石油A=0,'【今强势板块】:石油行业',IF(ZZDZ化纤A=0,'【今强势板块】:化纤行业',IF(ZZDZ造纸A=0,'【今强势板块】:造纸行业',IF(ZZDZ农林牧渔A=0,'【今强势板块】:农林牧渔',IF(ZZDZ酿酒A=0,'【今强势板块】:酿酒行业',IF(ZZDZ医疗保健A=0,'【今强势板块】:医疗保健',IF(ZZDZ商业连锁A=0,'【今强势板块】:商业连锁',IF(ZZDZ广告包装A=0,'【今强势板块】:广告包装',IF(ZZDZ旅游A=0,'【今强势板块】:旅游行业',IF(ZZDZ运输设备A=0,'【今强势板块】:运输设备',IF(ZZDZ电气设备A=0,'【今强势板块】:电气设备',
IF(ZZDZ电信运营A=0,'【今强势板块】:电信运营',IF(ZZDZ供气供热A=0,'【今强势板块】:供气供热',IF(ZZDZ仓储物流A=0,'【今强势板块】:仓储物流',IF(ZZDZ证券类A=0,'【今强势板块】:证券板块',IF(ZZDZ建筑A=0,'【今强势板块】:建筑行业',IF(ZZDZ通信设备A=0,'【今强势板块】:通信设备',IF(ZZDZ软件服务A=0,'【今强势板块】:软件服务',IF(ZZDZFINONE(245,0,1))/FINONE(245,0,1)*100;
HG111:=IF(环比增减1>0,VARCAT(VARCAT( '增加 ' ,VAR2STR( 环比增减1,2)),' % '),IF(环比增减1<0,VARCAT(VARCAT( '减少 ' ,VAR2STR(FINONE(242,0,1))/FINONE(242,0,1)*100,2),STRCAT(' %,',GDRSLXZJFX)))),COLORFFAAFF;
DRAWTEXT_FIX(ISLASTBAR AND ((FINVALUE(242)FINONE(247,0,1))/FINONE(247,0,1)*100,2),STRCAT(' % ',JGCGLXZJFX)))),COLORGREEN;
环比增减3:=(FINONE(284,0,0)-FINONE(284,0,1))/FINONE(284,0,1)*100;
HG333:=IF(环比增减3>0,VARCAT(VARCAT( '增加 ' ,VAR2STR( 环比增减3,2)),' % '),IF(环比增减3<0,VARCAT(VARCAT( '减少 ' ,VAR2STR(-环比增减3,2)),' % '),' '));
GJDCGLXFX:=IF(FINONE(284,0,0)<FINONE(284,0,1) AND FINONE(284,0,1)<FINONE(284,0,2) AND FINONE(284,0,2)<FINONE(284,0,3),'连续三季度减少',IF(FINVALUE(284)>FINONE(284,0,1) AND FINONE(284,0,1)>FINONE(284,0,2) AND FINONE(284,0,2)>FINONE(284,0,3),'连续三季度增加',''));
DRAWTEXT_FIX(ISLASTBAR,0.7,0.816,0,STRCAT('4、国家队持 ',STRCAT(CON2STR(FINVALUE(284),2),STRCAT(' 万股,占总股本 ',STRCAT(CON2STR(FINVALUE(284)*10000/FINVALUE(238)*100,2),' % '))))),COLORWHITE;
DRAWTEXT_FIX(ISLASTBAR,0.7,0.903,0,STRCAT('较上期 ',STRCAT(HG333,GJDCGLXFX))),COLORWHITE;

通达信行业分析加强版指标公式的选股公式