通达信K线状态主图指标公式

通达信K线状态主图指标公式

((HIGH REF(CLOSE,1))/REF(CLOSE,1)<0.03 AND
CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2)),1,0));
T2{黄昏之星}:=CONST(IF((REF(CLOSE,2)/REF(OPEN,2) > 1.03 AND REF(OPEN,1)
> REF(CLOSE,2) AND ABS(REF(OPEN,1)LOW) AND CLOSE > MA(CLOSE,5)),1,0));
T8{倒转锤头}:=CONST(IF((MIN(OPEN,CLOSE)=LOW AND HIGHLOW >
3*(HIGHMIN(OPEN,CLOSE)) AND CLOSE>MA(CLOSE,5)),1,0));
T11{穿头破脚}:=CONST(IF(((REF(CLOSE,1)/REF(OPEN,1)>1.03 AND CLOSE/OPEN<0.96
AND CLOSE<REF(OPEN,1)
AND OPEN>REF(CLOSE,1))OR (REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.04
AND CLOSE>REF(OPEN,1) AND OPEN<REF(CLOSE,1))),1,0));
T12{乌云盖顶}:=CONST(IF((REF(CLOSE,1)/REF(OPEN,1)>1.03 AND CLOSE/OPEN<0.97
AND OPEN>REF(CLOSE,1) AND CLOSE<REF(CLOSE,1)),1,0));
T13{曙光初现}:=CONST(IF((REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.03
AND OPEN<REF(CLOSE,1) AND CLOSE>REF(CLOSE,1)),1,0));
T14{身怀六甲}:=CONST(IF((ABS(REF(CLOSE,1)REF(OPEN,1))/REF(CLOSE,1) > 0.04
AND CLOSE=OPEN AND
CLOSE < MAX(REF(CLOSE,1),REF(OPEN,1)) AND CLOSE > MIN(REF(CLOSE,1)
,REF(OPEN,1))),1,0));
T16{平顶}:=CONST(IF((ABS(HIGHREF(LOW,2))/REF(LOW,1)<=0.001)),1,0));
T18{大阳烛}:=CONST(IF((CLOSE/OPEN>1.05 AND HIGH/LOW < CLOSE/OPEN+0.018),1,0));
T19{三个白武士}:=CONST(IF((REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)
>REF(OPEN,1) AND CLOSE>OPEN
AND REF(CLOSE,1)>REF(CLOSE,2) AND CLOSE>REF(CLOSE,1)),1,0));
T20{双飞乌鸦}:=CONST(IF((REF(CLOSE,1)<REF(OPEN,1) AND CLOSE<OPEN
AND CLOSE/OPEN<0.98),1,0));
T21{孕育线}:=CONST(IF((REF(CLOSE,2)>REF(OPEN,2) AND (REF(CLOSE,2)
OPEN)/OPEN>=2/100 AND CLOSE>=REF(OPEN,1) AND OPEN<=REF(CLOSE,1)
AND (MAX(CLOSE,REF(C,2))REF(OPEN,1))<0),1,0));
T31{长下影}:=CONST(IF(((MIN(CLOSE,OPEN)MAX(CLOSE,OPEN))/(HIGHREF(CLOSE,1))
/CLOSE<0.002)),1,0));
T36{倾盆大雨}:=CONST(IF((REF(C,1)/REF(O,1)>=1.03 AND O<REF(C,1) AND O
>REF(O,1) AND C<REF(O,1)),1,0));
T37{M9}:=CONST(V*比>REF(V,1) AND MA(V,5)>REF(MA(V,5),1));
T38{M10}:=CONST(V*比<REF(V,1) AND MA(V,5)>REF(MA(V,5),1));
T39{M11}:=CONST(V*比>REF(V,1)AND MA(V,5)<REF(MA(V,5),1));
T40{M12}:=CONST(V*比<REF(V,1)AND MA(V,5)<REF(MA(V,5),1));
T41{M13}:=CONST((((IF((CLOSE = OPEN),1,0) + IF((CLOSE >= J12),1,0)) + IF((CLOSE <= J23),1,0)) > 1));
T42{M14}:=CONST((((AMOUNT / VOL) / 100) > REF(HIGH,1)));
T43{M15}:=CONST((((AMOUNT / VOL) / 100) < REF(LOW,1)));
TS1:=IF(T1=1,0+0.03,0);
TS2:=IF(T2=1,TS1+0.03,TS1);
TS3:=IF(T3=1,TS2+0.03,TS2);
TS4:=IF(T4=1,TS3+0.03,TS3);
TS5:=IF(T5=1,TS4+0.03,TS4);
TS6:=IF(T6=1,TS5+0.03,TS5);
TS7:=IF(T7=1,TS6+0.03,TS6);
TS8:=IF(T8=1,TS7+0.03,TS7);
TS9:=IF(T9=1,TS8+0.03,TS8);
TS10:=IF(T10=1,TS9+0.03,TS9);
TS11:=IF(T11=1,TS10+0.03,TS10);
TS12:=IF(T12=1,TS11+0.03,TS11);
TS13:=IF(T13=1,TS12+0.03,TS12);
TS14:=IF(T14=1,TS13+0.03,TS13);
TS15:=IF(T15=1,TS14+0.03,TS14);
TS16:=IF(T16=1,TS15+0.03,TS15);
TS17:=IF(T17=1,TS16+0.03,TS16);
TS18:=IF(T18=1,TS17+0.03,TS17);
TS19:=IF(T19=1,TS18+0.03,TS18);
TS20:=IF(T20=1,TS19+0.03,TS19);
TS21:=IF(T21=1,TS20+0.03,TS20);
TS22:=IF(T22=1,TS21+0.03,TS21);
TS23:=IF(T23=1,TS22+0.03,TS22);
TS24:=IF(T24=1,TS23+0.03,TS23);
TS25:=IF(T25=1,TS24+0.03,TS24);
TS26:=IF(T26=1,TS25+0.03,TS25);
TS27:=IF(T27=1,TS26+0.03,TS26);
TS28:=IF(T28=1,TS27+0.03,TS27);
TS29:=IF(T29=1,TS28+0.03,TS28);
TS30:=IF(T30=1,TS29+0.03,TS29);
TS31:=IF(T31=1,TS30+0.03,TS30);
TS32:=IF(T32=1,TS31+0.03,TS31);
TS33:=IF(T33=1,TS32+0.03,TS32);
TS34:=IF(T34=1,TS33+0.03,TS33);
TS35:=IF(T35=1,TS34+0.03,TS34);
TS36:=IF(T36=1,TS35+0.03,TS35);
TS37:=IF(T37=1,TS36+0.03,TS36);
TS38:=IF(T38=1,TS37+0.03,TS37);
TS39:=IF(T39=1,TS38+0.03,TS38);
TS40:=IF(T40=1,TS39+0.03,TS39);
TS41:=IF(T41=1,TS40+0.03,TS40);
TS42:=IF(T42=1,TS41+0.03,TS41);
TS43:=IF(T43=1,TS42+0.03,TS42);
DRAWTEXT(T1=1 AND CURRBARSCOUNT=58,AAA(AAA*TS3),'长十字,重要的警告信号,原趋势停顿或反转‖'),COLOR00FFFF ;
DRAWTEXT(T4=1 AND CURRBARSCOUNT=58,AAA(AAA*TS6),'黄昏十字星,趋势停顿或反转,下跌或,见顶回落‖'),COLORFFFF00 ;
DRAWTEXT(T7=1 AND CURRBARSCOUNT=58,AAA(AAA*TS9),'锤头,可能见底回升,如有量配合,信号强烈‖'),COLOR0000FF ;
DRAWTEXT(T10=1 AND CURRBARSCOUNT=58,AAA(AAA*TS12),'乌云盖顶,见顶回落信号‖'),COLORFFFF00 ;
DRAWTEXT(T13=1 AND CURRBARSCOUNT=58,AAA(AAA*TS15),'十字胎‖'),COLOR00FFFF ;
DRAWTEXT(T16=1 AND CURRBARSCOUNT=58,AAA(AAA*TS18),'大阳烛,上升中,剧烈地向上攀升。下行中,剧烈地向上反弹‖'),COLOR0000FF ;
DRAWTEXT(T19=1 AND CURRBARSCOUNT=58,AAA(AAA*TS21),'孕育线,注意股价位置‖'),COLOR00FFFF ;
DRAWTEXT(T22=1 AND CURRBARSCOUNT=58,AAA(AAA*TS24),'上升三部曲,上涨信号‖'),COLORFF00FF ;
DRAWTEXT(T25=1 AND CURRBARSCOUNT=58,AAA(AAA*TS27),'三只乌鸦站枝头,可能见顶回落‖'),COLORFFFF00 ;
DRAWTEXT(T28=1 AND CURRBARSCOUNT=58,AAA(AAA*TS30),'分离,注意看涨分离和看跌分离‖'),COLOR00FFFF ;
DRAWTEXT(T31=1 AND CURRBARSCOUNT=58,AAA(AAA*TS33),'十字星,重要的警告信号,原趋势停顿或反转‖'),COLOR00FFFF ;
DRAWTEXT(T34=1 AND CURRBARSCOUNT=58,AAA(AAA*TS36),'倾盆大雨,见顶信号‖'),COLORFFFF00 ;
DRAWTEXT(T37=1 AND CURRBARSCOUNT=58,AAA(AAA*TS39),'今日成交量大于昨日, 但有缩小迹象'),COLORRED ;
DRAWTEXT(T40=1 AND CURRBARSCOUNT=58,AAA(AAA*TS42),'上涨趋势'),COLORRED ;
DRAWTEXT(T43=1 AND CURRBARSCOUNT=58,AAA-(AAA*TS43),'下跌趋势'),COLORGREEN ;

通达信K线状态主图指标公式的选股公式