通达信MACD背离钝化指标公式

指标公式 14次浏览

通达信MACD背离钝化指标公式

EMA(CLOSE,26),COLORWHITE;
DEA:EMA(DIFF,12),COLORYELLOW;
MACD=2*(DIFF1,INTPART(LOG(1,INTPART(LOG(1,INTPART(LOG(1,INTPART(LOG(-DIFH3))-1);
MDIFH3:=INTPART(DIFH3/POW(10,PDIFH3));
MDIFT2:=INTPART(DIFF/POW(10,PDIFH2));
MDIFT3:=INTPART(DIFF/POW(10,PDIFH3));
直接顶背离:=(CH1>CH2 ) AND (MDIFT2<MDIFH2) AND (MACD>0 AND REF(MACD,1)>0) AND MDIFT2>=REF(MDIFT2,1);
隔峰顶背离:=(CH1>CH3 AND CH3>CH2 ) AND (MDIFT3<MDIFH3) AND (MACD>0 AND REF(MACD,1)>0) AND MDIFT3>=REF(MDIFT3,1);
T:=直接顶背离 OR 隔峰顶背离,NODRAW;
TG:=((MDIFT2<REF(MDIFT2,1))*REF(直接顶背离,1)) OR ((MDIFT3<REF(MDIFT3,1))*REF(隔峰顶背离,1)),NODRAW;
顶背离消失:=(REF(直接顶背离,1) AND DIFH1>=DIFH2 ) OR (REF(隔峰顶背离,1) AND DIFH1>=DIFH3);
STICKLINE(TG,0,DIFF+DEA,5,0), COLORGREEN,LINETHICK4;
STICKLINE(T OR TG,DIFF,DEA,8,0),COLORGREEN,LINETHICK2;
DRAWTEXT(FILTER(TG,20),DIFF*1.4,’成’),COLORMAGENTA;
DRAWTEXT(FILTER(顶背离消失,20),(DIFF+MACD),’失’),COLORGREEN;

通达信MACD背离钝化指标公式的选股公式


喜欢 (0)