通达信优化MACD顶底指标公式

指标公式 13次浏览

通达信优化MACD顶底指标公式

EMA(CLOSE,19);
DEA:EMA(DIFF,9);
DRAWBAND(DIFF,RGB(200,50,55),DEA,RGB(50,100,10));
MACD:2*(DIFF0.1,0,1,0),COLORFF00FF;
STICKLINE(B3>0,0.1,0),COLORFF00FF,POINTDOT;
RSI底背:IF(B3>0,-0.1,0),COLORYELLOW,POINTDOT;
MACD顶背:IF(D1>0,0.1,0),COLOR00FF00,POINTDOT;
KDJ顶背:IF(D2>0,0.1,0),COLORFFCC66,POINTDOT;
RSI顶背:IF(D3>0,0.1,0),COLORWHITE,POINTDOT;
强:IF(DIFF>MA(DIFF,2),DIFF,DRAWNULL),COLORRED,LINETHICK2;
弱:IF(DEA>MA(DEA,2),DEA,DRAWNULL),COLORMAGENTA,LINETHICK2;
DRAWICON(CROSS(DIFF,DEA),DEA,5);
DRAWICON(CROSS(DEA,DIFF),DEA,27);
A:=REF(DIFF,1)<REF(DIFF,2) AND REF(DIFF,2)<REF(DIFF,3) AND DIFF>REF(DIFF,1);
B:=REF(DIFF,1)>REF(DIFF,2) AND REF(DIFF,2)>REF(DIFF,3) AND DIFF<REF(DIFF,1);
DRAWICON(A,DIFF,1);
DRAWICON(B,DIFF,2);
STICKLINE((MACD > 0),0,MACD,0.1,0),COLOR0000CC;
STICKLINE((MACD > 0),0,MACD*0.9,0.1,0),COLOR0000EE;
STICKLINE((MACD > 0),0,MACD*0.8,0.1,0),COLOR0011FF;
STICKLINE((MACD > 0),0,MACD*0.7,0.1,0),COLOR0033FF;
STICKLINE((MACD > 0),0,MACD*0.6,0.1,0),COLOR0055FF;
STICKLINE((MACD > 0),0,MACD*0.5,0.1,0),COLOR0077FF;
STICKLINE((MACD > 0),0,MACD*0.4,0.1,0),COLOR0099FF;
STICKLINE((MACD > 0),0,MACD*0.3,0.1,0),COLOR00BBFF;
STICKLINE((MACD > 0),0,MACD*0.2,0.1,0),COLOR00DDFF;
STICKLINE((MACD > 0),0,MACD*0.1,0.1,0),COLOR00FFFF;
STICKLINE((MACD < 0),0,MACD,0.1,0),COLORCC0033;
STICKLINE((MACD < 0),0,MACD*0.9,0.1,0),COLOREE0033;
STICKLINE((MACD < 0),0,MACD*0.8,0.1,0),COLORFF1133;
STICKLINE((MACD < 0),0,MACD*0.7,0.1,0),COLORFF3333;
STICKLINE((MACD < 0),0,MACD*0.6,0.1,0),COLORFF5533;
STICKLINE((MACD < 0),0,MACD*0.5,0.1,0),COLORFF7733;
STICKLINE((MACD < 0),0,MACD*0.4,0.1,0),COLORFF9933;
STICKLINE((MACD < 0),0,MACD*0.3,0.1,0),COLORFFBB33;
STICKLINE((MACD < 0),0,MACD*0.2,0.1,0),COLORFFDD33;
STICKLINE((MACD < 0),0,MACD*0.1,0.1,0),COLORFFFF33;

通达信优化MACD顶底指标公式的选股公式


喜欢 (0)